summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-31 12:27:36 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-31 12:27:36 (GMT)
commit36bb624907cd2eec30c8bbfe4787e29685b80947 (patch)
tree192996737bce258d5ace2c077c18156d4411a33a /Source/QtDialog/CMakeLists.txt
parent121df27fa207a233677fbdc1a0ab738593cf280c (diff)
downloadCMake-36bb624907cd2eec30c8bbfe4787e29685b80947.zip
CMake-36bb624907cd2eec30c8bbfe4787e29685b80947.tar.gz
CMake-36bb624907cd2eec30c8bbfe4787e29685b80947.tar.bz2
Fix installation when built by CMake 2.4
CMake 2.4 generates old-style cmake_install.cmake code including calls to the file(INSTALL) command with the COMPONENTS argument. We need to set CMAKE_INSTALL_SELF_2_4 for the whole install tree to prevent the command from complaining in this special case. Previously this was needed only in the QtDialog directory, but now it is needed in the entire tree.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 82bb7db..d66f171 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -74,11 +74,6 @@ ELSE(NOT QT4_FOUND)
ENDIF(APPLE)
SET(CMAKE_INSTALL_DESTINATION_ARGS
BUNDLE DESTINATION "${CMAKE_BUNDLE_LOCATION}")
- ELSE(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
- # Since the built CMake will install itself instead of the
- # generating CMake, tell it that the install rules were generated
- # by CMake 2.4.
- INSTALL(CODE "SET(CMAKE_INSTALL_SELF_2_4 1)")
ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
# if qt is not static and we are on windows then skip the install
# I don't want to distribute qt dlls