summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Jomier <julien.jomier@kitware.com>2018-11-17 13:01:23 (GMT)
committerJulien Jomier <julien.jomier@kitware.com>2018-11-20 16:16:08 (GMT)
commit9175a378f5d8786a54e35576853e7e6b068f17b0 (patch)
tree70efe7860c9b4f5447e5db7c80069cacb3ee0bae /Source/QtDialog/CMakeLists.txt
parent7aa41095fd23d31a4572966ba53ad85f61f5bc99 (diff)
downloadCMake-9175a378f5d8786a54e35576853e7e6b068f17b0.zip
CMake-9175a378f5d8786a54e35576853e7e6b068f17b0.tar.gz
CMake-9175a378f5d8786a54e35576853e7e6b068f17b0.tar.bz2
QtDialog: Add windows taskbar progress
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 330b747..9ce0323 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -19,9 +19,20 @@ if (Qt5Widgets_FOUND)
macro(qt4_add_resources)
qt5_add_resources(${ARGN})
endmacro()
+
set(CMake_QT_LIBRARIES ${Qt5Widgets_LIBRARIES})
set(QT_QTMAIN_LIBRARY ${Qt5Core_QTMAIN_LIBRARIES})
+ # Try to find the package WinExtras for the task bar progress
+ if(WIN32)
+ find_package(Qt5WinExtras QUIET)
+ if (Qt5WinExtras_FOUND)
+ include_directories(${Qt5WinExtras_INCLUDE_DIRS})
+ add_definitions(-DQT_WINEXTRAS)
+ list(APPEND CMake_QT_LIBRARIES ${Qt5WinExtras_LIBRARIES})
+ endif()
+ endif()
+
# Remove this when the minimum version of Qt is 4.6.
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0)