summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-06-17 19:02:54 (GMT)
committerBrad King <brad.king@kitware.com>2016-06-17 19:02:54 (GMT)
commit9ad10c8feb9ffd0adf0840379eedbae4df49ffd7 (patch)
treefa47a30421aca853983b15c34485150ffe7cca51 /Source/QtDialog/CMakeLists.txt
parent9e4725560493fdac423102469da6dbe1779383c4 (diff)
downloadCMake-9ad10c8feb9ffd0adf0840379eedbae4df49ffd7.zip
CMake-9ad10c8feb9ffd0adf0840379eedbae4df49ffd7.tar.gz
CMake-9ad10c8feb9ffd0adf0840379eedbae4df49ffd7.tar.bz2
cmake-gui: Reference LGPLv3 when redistributing Qt
Download http://www.gnu.org/licenses/lgpl.txt and place it as Licenses/LGPLv3.txt in our source tree. When building cmake-gui, use option CMake_GUI_DISTRIBUTE_WITH_Qt_LGPL to enable notification in the "About" dialog of how the distribution of Qt is licensed. Install the license file as ${CMAKE_ROOT}/Licenses/LGPLv3.txt so that the dialog can display a path to it.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index a906f4a..68c65ac 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -150,12 +150,12 @@ if(APPLE)
MACOSX_PACKAGE_LOCATION Resources)
endif()
-if(CMake_GUI_DISTRIBUTE_WITH_Qt_LGPL)
- install(FILES ${CMake_SOURCE_DIR}/Licenses/LGPLv2.1.txt
+if(USE_LGPL)
+ install(FILES ${CMake_SOURCE_DIR}/Licenses/LGPLv${USE_LGPL}.txt
DESTINATION ${CMAKE_DATA_DIR}/Licenses
${COMPONENT})
set_property(SOURCE CMakeSetupDialog.cxx
- PROPERTY COMPILE_DEFINITIONS CMake_GUI_DISTRIBUTE_WITH_Qt_LGPL)
+ PROPERTY COMPILE_DEFINITIONS USE_LGPL="${USE_LGPL}")
endif()
set(CMAKE_INCLUDE_CURRENT_DIR ON)