summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2012-01-02 18:07:43 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2012-01-02 18:07:43 (GMT)
commit131eed660716a2a8b52a6956f8e8a136425c404e (patch)
tree99ba06a0196fc4bc6e8eb84b1ff75fc984e89b92 /Source/QtDialog/CMakeLists.txt
parent40aedcbbaeddcb7e088c56e30f4252171e920baa (diff)
downloadCMake-131eed660716a2a8b52a6956f8e8a136425c404e.zip
CMake-131eed660716a2a8b52a6956f8e8a136425c404e.tar.gz
CMake-131eed660716a2a8b52a6956f8e8a136425c404e.tar.bz2
cmake-gui: Improve interrupt granularity to fix bug 12649.
Instead of enabling interrupt only when a progress or message callback is called, add a new callback specifically for interrupt. This new callback is called from GetFatalErrorOccured() so cmake-gui can immediately report interrupt status instead of calling queuing a call to cmSystemTools::SetFatalErrorOccured() and waiting for the progress or message callback to be called to process that queued call.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 4785188..056e48e 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -10,11 +10,11 @@
# See the License for more information.
#=============================================================================
PROJECT(QtDialog)
-SET(QT_MIN_VERSION "4.3.0")
+SET(QT_MIN_VERSION "4.4.0")
FIND_PACKAGE(Qt4 REQUIRED)
IF(NOT QT4_FOUND)
- MESSAGE(SEND_ERROR "Failed to find Qt 4.3 or greater.")
+ MESSAGE(SEND_ERROR "Failed to find Qt 4.4 or greater.")
ELSE(NOT QT4_FOUND)
INCLUDE(${QT_USE_FILE})