summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Pfeifer <daniel@pfeifer-mail.de>2017-04-28 07:45:21 (GMT)
committerDaniel Pfeifer <daniel@pfeifer-mail.de>2017-04-28 07:45:21 (GMT)
commitb13bc8659f87567b1b091806d42f5023b2a6b48b (patch)
tree3d6b66e5667b33248ab3241b1d61835ee79dfbb1 /Source/QtDialog/CMakeLists.txt
parent5081dfca8332957a4894bce0653c86ba1b7b2bfe (diff)
downloadCMake-b13bc8659f87567b1b091806d42f5023b2a6b48b.zip
CMake-b13bc8659f87567b1b091806d42f5023b2a6b48b.tar.gz
CMake-b13bc8659f87567b1b091806d42f5023b2a6b48b.tar.bz2
Disable clang-tidy checks on files generated by Qt
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 2e11a8a..8619fe9 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -160,6 +160,19 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
add_executable(cmake-gui WIN32 MACOSX_BUNDLE ${SRCS} ${MANIFEST_FILE})
target_link_libraries(cmake-gui CMakeLib ${QT_QTMAIN_LIBRARY} ${CMake_QT_LIBRARIES})
+# Files generated by MOC, RCC, and UIC may produce clang-tidy warnings.
+# We generate a dummy .clang-tidy file in the binary directory that disables
+# all clang-tidy checks except one that will never match. This one check is
+# necessary; clang-tidy reports an error when no checks are enabled.
+# Since the Qt code generators will generate source files in the binary tree,
+# clang-tidy will load the configuration from this dummy file when the sources
+# are built.
+file(WRITE "${QtDialog_BINARY_DIR}/.clang-tidy" "
+---
+Checks: '-*,llvm-twine-local'
+...
+")
+
if(APPLE)
file(STRINGS "${CMake_SOURCE_DIR}/Copyright.txt" copyright_line
LIMIT_COUNT 1 REGEX "^Copyright 2000-20[0-9][0-9] Kitware")