summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-02-16 18:05:03 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2008-02-16 18:05:03 (GMT)
commit22927ede1e74e43ad78699ff4082d8b78e50599c (patch)
tree6f6bd3e1613623e7f9e7356ef798a02fe553df84 /Source/QtDialog/CMakeLists.txt
parent337c1f0b7230d6b0b4674d1d7168eef5a6dce6cd (diff)
downloadCMake-22927ede1e74e43ad78699ff4082d8b78e50599c.zip
CMake-22927ede1e74e43ad78699ff4082d8b78e50599c.tar.gz
CMake-22927ede1e74e43ad78699ff4082d8b78e50599c.tar.bz2
ENH: support for cpack and install of cmake-gui as mac app bundle
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 1b9119c..31d8309 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -54,10 +54,15 @@ ELSE(NOT QT4_FOUND)
ADD_EXECUTABLE(cmake-gui WIN32 MACOSX_BUNDLE ${SRCS})
TARGET_LINK_LIBRARIES(cmake-gui CMakeLib ${QT_QTMAIN_LIBRARY} ${QT_LIBRARIES})
+ IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
+ SET(CMAKE_INSTALL_DESTINATION_ARGS
+ BUNDLE DESTINATION "${CMAKE_BUNDLE_LOCATION}")
+ ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
# if qt is not static and we are on windows then skip the install
# I don't want to distribute qt dlls
IF(CMAKE_PACKAGE_QTGUI)
- INSTALL_TARGETS(/bin cmake-gui)
+ INSTALL(TARGETS cmake-gui RUNTIME DESTINATION bin
+ ${CMAKE_INSTALL_DESTINATION_ARGS})
ENDIF(CMAKE_PACKAGE_QTGUI)
ENDIF(NOT QT4_FOUND)