summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Scott <michael.scott250@gmail.com>2015-12-06 12:33:13 (GMT)
committerBrad King <brad.king@kitware.com>2015-12-10 14:28:31 (GMT)
commit67211011d946684bed73bcd5b976ec90f4c30856 (patch)
treee6300f4a87a753feaccfcce2fca254913ef30ee7 /Source/QtDialog/CMakeLists.txt
parent128d569af02d95e455b5ee1d8dddec07251b7033 (diff)
downloadCMake-67211011d946684bed73bcd5b976ec90f4c30856.zip
CMake-67211011d946684bed73bcd5b976ec90f4c30856.tar.gz
CMake-67211011d946684bed73bcd5b976ec90f4c30856.tar.bz2
cmake-gui: Add options to control warning messages
Create a new dialog window for the cmake-gui that provides controls for setting the state of suppression of developer and deprecated warning messages. This replaces the previous single checkbox for setting the state of suppression of developer warnings. Added a note for the new functionality to the release notes.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index cad11f5..9161ad3 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -115,6 +115,8 @@ set(SRCS
QCMakeWidgets.h
RegexExplorer.cxx
RegexExplorer.h
+ WarningMessagesDialog.cxx
+ WarningMessagesDialog.h
)
QT4_WRAP_UI(UI_SRCS
CMakeSetupDialog.ui
@@ -122,6 +124,7 @@ QT4_WRAP_UI(UI_SRCS
CrossCompiler.ui
AddCacheEntry.ui
RegexExplorer.ui
+ WarningMessagesDialog.ui
)
QT4_WRAP_CPP(MOC_SRCS
AddCacheEntry.h
@@ -132,6 +135,7 @@ QT4_WRAP_CPP(MOC_SRCS
QCMakeCacheView.h
QCMakeWidgets.h
RegexExplorer.h
+ WarningMessagesDialog.h
)
QT4_ADD_RESOURCES(RC_SRCS CMakeSetup.qrc)