summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-02-20 22:23:11 (GMT)
committerBrad King <brad.king@kitware.com>2023-02-20 22:55:49 (GMT)
commit5cda8a399398020bba462bbf70609d3a37bb8c18 (patch)
tree88f28b0c01519394279300fbbed0bea298792058 /Source/QtDialog/CMakeLists.txt
parentd18806e67336d96a9a22b860246de3f1c518ce40 (diff)
downloadCMake-5cda8a399398020bba462bbf70609d3a37bb8c18.zip
CMake-5cda8a399398020bba462bbf70609d3a37bb8c18.tar.gz
CMake-5cda8a399398020bba462bbf70609d3a37bb8c18.tar.bz2
cmake-gui: Fix conversion warnings about Qt indexing types
Qt 5 uses `int` for indexing, and Qt 6 uses `qsizetype`. Add helper types and casts to the appropriate type to avoid conversion warnings.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index c90b7ee..e6e41ec 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -175,6 +175,7 @@ add_library(
QCMakePresetComboBox.h
QCMakePresetItemModel.cxx
QCMakePresetItemModel.h
+ QCMakeSizeType.h
QCMakeWidgets.cxx
QCMakeWidgets.h
RegexExplorer.cxx