summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-02-18 15:26:28 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2008-02-18 15:26:28 (GMT)
commitef537ffec7715c4249b3476307014292955e47c2 (patch)
tree7b018fa0cfb259d05dd648166001c2bcb7175a30 /Source/QtDialog/CMakeLists.txt
parentc51a45466dea6d375a089130edf615b47457c593 (diff)
downloadCMake-ef537ffec7715c4249b3476307014292955e47c2.zip
CMake-ef537ffec7715c4249b3476307014292955e47c2.tar.gz
CMake-ef537ffec7715c4249b3476307014292955e47c2.tar.bz2
ENH: have cpack work with DESTDIR install and ingest qt framework libs into cmake-gui
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index 31d8309..726f42e 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -64,6 +64,10 @@ ELSE(NOT QT4_FOUND)
INSTALL(TARGETS cmake-gui RUNTIME DESTINATION bin
${CMAKE_INSTALL_DESTINATION_ARGS})
ENDIF(CMAKE_PACKAGE_QTGUI)
-
+ IF(APPLE)
+ INSTALL(CODE "set(input_file
+ \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/MacOS/cmake-gui\")")
+ INSTALL(SCRIPT "${CMake_SOURCE_DIR}/Source/QtDialog/CMakeIngestOSXBundleLibraries.cmake")
+ ENDIF(APPLE)
ENDIF(NOT QT4_FOUND)