summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2003-06-30 01:42:48 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2003-06-30 01:42:48 (GMT)
commit0f1af706b5dcb42077c1831df35a8b0e03f26a20 (patch)
tree38f7b76434394ab623c4017d30bed912de1a8d4c /Source/kwsys/CMakeLists.txt
parent823c073052644fc05e70edf6122e88704cca5136 (diff)
downloadCMake-0f1af706b5dcb42077c1831df35a8b0e03f26a20.zip
CMake-0f1af706b5dcb42077c1831df35a8b0e03f26a20.tar.gz
CMake-0f1af706b5dcb42077c1831df35a8b0e03f26a20.tar.bz2
ENH: Initial import of Base64
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 7d60b40..4b4f73e 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -211,6 +211,9 @@ ENDFOREACH(c)
IF(KWSYS_USE_Process)
SET(KWSYS_H_FILES ${KWSYS_H_FILES} Process)
ENDIF(KWSYS_USE_Process)
+IF(KWSYS_USE_Base64)
+ SET(KWSYS_H_FILES ${KWSYS_H_FILES} Base64)
+ENDIF(KWSYS_USE_Base64)
#-----------------------------------------------------------------------------
# Build a list of sources for the library based on components that are
@@ -230,6 +233,11 @@ IF(KWSYS_USE_Process)
ENDIF(NOT UNIX)
ENDIF(KWSYS_USE_Process)
+# Add proper sources for Base64 encoding
+IF(KWSYS_USE_Base64)
+ SET(KWSYS_SRCS ${KWSYS_SRCS} Base64.c)
+ENDIF(KWSYS_USE_Base64)
+
# Configure headers of C++ classes and construct the list of sources.
FOREACH(c ${KWSYS_CLASSES})
# Add this source to the list of source files for the library.