summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2005-03-25 13:41:57 (GMT)
committerBrad King <brad.king@kitware.com>2005-03-25 13:41:57 (GMT)
commite0cfb268b6b7919824403ac1b4d20d1497edaf83 (patch)
tree8c178de55c83b6ea03354ed333dbf44d2be22851 /Source/kwsys/CMakeLists.txt
parent4ba14d1278796d6b82f3b5bb89a6121ba4e4ff76 (diff)
downloadCMake-e0cfb268b6b7919824403ac1b4d20d1497edaf83.zip
CMake-e0cfb268b6b7919824403ac1b4d20d1497edaf83.tar.gz
CMake-e0cfb268b6b7919824403ac1b4d20d1497edaf83.tar.bz2
ENH: Adding SharedForward C header to help create forwarding executables on UNIX systems that configure the shared library runtime search path and then replace themselves with the real executable. This is useful to create binary distributions that work from any extracted location even with shared libraries.
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 48732d6..c3455f3 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -245,7 +245,7 @@ ENDFOREACH(header)
# Build a list of classes and headers we need to implement the
# selected components. Initialize with required components.
SET(KWSYS_CLASSES)
-SET(KWSYS_H_FILES Configure)
+SET(KWSYS_H_FILES Configure SharedForward)
SET(KWSYS_HXX_FILES Configure)
# Enforce component dependencies.