summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-10-18 18:08:55 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-10-18 18:08:55 (GMT)
commitfdc4795b9131d43bc06a4051eac1ddeb11c2bce7 (patch)
tree652a89168aa97eb39719ab8d7de64cbfe287786a /Source/kwsys/CMakeLists.txt
parent37dc4bdc6e96ac66c0c95c3c977498a502604fe1 (diff)
downloadCMake-fdc4795b9131d43bc06a4051eac1ddeb11c2bce7.zip
CMake-fdc4795b9131d43bc06a4051eac1ddeb11c2bce7.tar.gz
CMake-fdc4795b9131d43bc06a4051eac1ddeb11c2bce7.tar.bz2
ENH: Push glob to the kwsys
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index c0b4f66..38254b1 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -86,6 +86,7 @@ IF(KWSYS_STANDALONE OR CMake_SOURCE_DIR)
# Enable all components.
SET(KWSYS_USE_Base64 1)
SET(KWSYS_USE_Directory 1)
+ SET(KWSYS_USE_Glob 1)
SET(KWSYS_USE_Process 1)
SET(KWSYS_USE_RegularExpression 1)
SET(KWSYS_USE_Registry 1)
@@ -416,9 +417,14 @@ SET(KWSYS_HXX_FILES Configure hashtable hash_fun hash_map hash_set)
IF(KWSYS_USE_SystemTools)
SET(KWSYS_USE_Directory 1)
ENDIF(KWSYS_USE_SystemTools)
+IF(KWSYS_USE_Glob)
+ SET(KWSYS_USE_Directory 1)
+ SET(KWSYS_USE_SystemTools 1)
+ SET(KWSYS_USE_RegularExpression 1)
+ENDIF(KWSYS_USE_Glob)
# Add selected C++ classes.
-SET(cppclasses Directory RegularExpression SystemTools CommandLineArguments Registry)
+SET(cppclasses Directory Glob RegularExpression SystemTools CommandLineArguments Registry)
FOREACH(c ${cppclasses})
IF(KWSYS_USE_${c})
SET(KWSYS_CLASSES ${KWSYS_CLASSES} ${c})