summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorMathieu Malaterre <mathieu.malaterre@gmail.com>2006-03-10 19:53:42 (GMT)
committerMathieu Malaterre <mathieu.malaterre@gmail.com>2006-03-10 19:53:42 (GMT)
commitc0161e9e57321f283fc88812779d627fb722a40a (patch)
tree90e38c8412a44f18a2f46ecd4e1e5321b223cee4 /Source/kwsys/CMakeLists.txt
parent89e5fc63fec560bec27d8517cc74ec41232736a0 (diff)
downloadCMake-c0161e9e57321f283fc88812779d627fb722a40a.zip
CMake-c0161e9e57321f283fc88812779d627fb722a40a.tar.gz
CMake-c0161e9e57321f283fc88812779d627fb722a40a.tar.bz2
BUG: Trying to get testDynamicLoader to work on Solaris and SunOS, where current directory is not lookup when doing dlopen
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 6771d26..faae76f 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -516,6 +516,7 @@ IF(KWSYS_C_SRCS OR KWSYS_CXX_SRCS)
# If kwsys contains the DynamicLoader, need extra library
IF(KWSYS_USE_DynamicLoader)
ADD_LIBRARY(testDynload MODULE testDynload.c)
+ GET_TARGET_PROPERTY(TEST_DYNLOAD_LOCATION testDynload LOCATION)
IF(UNIX)
TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE} ${CMAKE_DL_LIBS})
ENDIF(UNIX)