summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-01-16 19:06:29 (GMT)
committerBrad King <brad.king@kitware.com>2017-01-16 19:06:29 (GMT)
commitee77941a1fdf3a617207b00a7f2e9315eaef7b31 (patch)
tree9fa7da0722af50bd783b33961e931c2b687b1d82 /Source/kwsys/CMakeLists.txt
parent35ad12f99e71515f9cc65b1219160b88095a5f6b (diff)
parent219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7 (diff)
downloadCMake-ee77941a1fdf3a617207b00a7f2e9315eaef7b31.zip
CMake-ee77941a1fdf3a617207b00a7f2e9315eaef7b31.tar.gz
CMake-ee77941a1fdf3a617207b00a7f2e9315eaef7b31.tar.bz2
Merge branch 'upstream-KWSys' into update-kwsys
* upstream-KWSys: KWSys 2017-01-16 (a423d829)
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 9eb3b2d..d4fe8a7 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -818,6 +818,9 @@ IF(KWSYS_C_SRCS OR KWSYS_CXX_SRCS)
# for symbol lookup using dladdr
TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE} ${CMAKE_DL_LIBS})
ENDIF()
+ IF (CMAKE_SYSTEM_NAME STREQUAL "SunOS")
+ TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE} socket)
+ ENDIF()
ENDIF()
ENDIF()