summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2006-10-06 15:13:02 (GMT)
committerDavid Cole <david.cole@kitware.com>2006-10-06 15:13:02 (GMT)
commit22442fd9e120e88676916fcba313217a8851d41a (patch)
treeb112545d5149916abc27be56f1e3de13cccac8ac /Source/kwsys/CMakeLists.txt
parent017cec95ada69369e3959cc9c09248335ea2dbfa (diff)
downloadCMake-22442fd9e120e88676916fcba313217a8851d41a.zip
CMake-22442fd9e120e88676916fcba313217a8851d41a.tar.gz
CMake-22442fd9e120e88676916fcba313217a8851d41a.tar.bz2
STYLE: Make the set of supported STL headers the same in vtkstd and vtksys/stl. (The union of the present values of the two sets.)
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 54ff8b8..e3f8ff2 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -501,8 +501,25 @@ INCLUDE_DIRECTORIES(${KWSYS_HEADER_ROOT})
# Create STL header wrappers to block warnings in the STL headers and
# give standard names by which they may be included.
SET(KWSYS_STL_HEADER_EXTRA_string 1)
-FOREACH(header algorithm deque iterator list map numeric queue set stack string
- utility vector memory functional)
+FOREACH(header
+ algorithm
+ deque
+ exception
+ functional
+ iterator
+ list
+ map
+ memory
+ new
+ numeric
+ queue
+ set
+ stack
+ stdexcept
+ string
+ utility
+ vector
+ )
# Configure the header wrapper.
SET(KWSYS_STL_HEADER "${header}")
IF(KWSYS_STL_HEADER_EXTRA_${header})