summaryrefslogtreecommitdiffstats
path: root/Source/kwsys/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2003-06-23 12:56:03 (GMT)
committerBrad King <brad.king@kitware.com>2003-06-23 12:56:03 (GMT)
commitbe1fd8bfb58912f3fc518a4a6641d0a99c737231 (patch)
tree2c0054560eb4d489bc3dd46d2f95c7ed2babcccb /Source/kwsys/CMakeLists.txt
parent324807d395f6c516337478e94958b39037f65f22 (diff)
downloadCMake-be1fd8bfb58912f3fc518a4a6641d0a99c737231.zip
CMake-be1fd8bfb58912f3fc518a4a6641d0a99c737231.tar.gz
CMake-be1fd8bfb58912f3fc518a4a6641d0a99c737231.tar.bz2
BUG: Need include regular expression to match all files.
Diffstat (limited to 'Source/kwsys/CMakeLists.txt')
-rw-r--r--Source/kwsys/CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
index 2eafc9d..5f83623 100644
--- a/Source/kwsys/CMakeLists.txt
+++ b/Source/kwsys/CMakeLists.txt
@@ -83,6 +83,9 @@ ENDIF(NOT KWSYS_NAMESPACE)
# The project name is that of the specified namespace.
PROJECT(${KWSYS_NAMESPACE})
+# Do full dependency headers.
+INCLUDE_REGULAR_EXPRESSION("^.*$")
+
# Work-around for CMake 1.6.7 bug in custom command dependencies when
# there is no executable output path.
IF(NOT EXECUTABLE_OUTPUT_PATH)
@@ -189,11 +192,11 @@ SET(KWSYS_CLASSES)
SET(KWSYS_H_FILES)
SET(KWSYS_HXX_FILES Configure)
-# Enforce component dependencies.
-IF(KWSYS_USE_SystemTools)
- SET(KWSYS_USE_Directory 1)
- SET(KWSYS_USE_RegularExpression 1)
-ENDIF(KWSYS_USE_SystemTools)
+# Enforce component dependencies (none currently exists).
+#IF(KWSYS_USE_SystemTools)
+# SET(KWSYS_USE_Directory 1)
+# SET(KWSYS_USE_RegularExpression 1)
+#ENDIF(KWSYS_USE_SystemTools)
# Add selected C++ classes.
FOREACH(c Directory RegularExpression SystemTools)