summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-06-29 13:30:01 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-06-29 13:30:01 (GMT)
commit08460462006d3d3a050317476fff4c8961da01c5 (patch)
treef550980fcc025f1206bf834bc6bc375b6a3a575f /Templates/configure.in
parenta7f7366abdff30b8891a2d4c94e33f4e4760c42b (diff)
downloadCMake-08460462006d3d3a050317476fff4c8961da01c5.zip
CMake-08460462006d3d3a050317476fff4c8961da01c5.tar.gz
CMake-08460462006d3d3a050317476fff4c8961da01c5.tar.bz2
BUG: break up CMAKE_AR into program and ARGS
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index f75b573..5699375 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -542,7 +542,8 @@ fi
# find make to use to build cmake, prefer gmake
AC_PATH_PROGS(RUNMAKE, gmake make)
AC_PATH_PROGS(CMAKE_AR_TMP, ar)
-CMAKE_AR="$CMAKE_AR_TMP cr"
+CMAKE_AR="$CMAKE_AR_TMP"
+CMAKE_AR_ARGS="cr"
# if on SunOS and not using gXX then use the compiler to make .a libs
case $system in
SunOS-5*)
@@ -551,9 +552,11 @@ case $system in
else
echo "Using $CXX -xar -o for creating .a libraries"
CMAKE_AR="$CXX -xar -o"
+ CMAKE_AR_ARGS="-xar -o"
fi
esac
AC_SUBST(CMAKE_AR)
+AC_SUBST(CMAKE_AR_ARGS)
# generate output files.
# create mkdir files just to make some of the directories