summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-07-05 22:15:05 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-07-05 22:15:05 (GMT)
commit9fb9493137eab9042dc89c51fea978ca6adf0907 (patch)
treeb5f5fbb5eab362b1e06f277db321a76f71582621 /Templates/configure.in
parent05fb9379efa81ae3b4de42ee3055586b52298dff (diff)
downloadCMake-9fb9493137eab9042dc89c51fea978ca6adf0907.zip
CMake-9fb9493137eab9042dc89c51fea978ca6adf0907.tar.gz
CMake-9fb9493137eab9042dc89c51fea978ca6adf0907.tar.bz2
BUG: fix flags for cygwin and shared builds
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index ae8a074..01a2d02 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -182,8 +182,9 @@ case $system in
CYGWIN_NT*)
CMAKE_SHLIB_CFLAGS=""
CMAKE_DL_LIBS="-lgdi32"
+ CMAKE_SHLIB_BUILD_FLAGS="-shared"
CMAKE_SHLIB_SUFFIX=".dll"
- CMAKE_SHLIB_LINK_FLAGS="-shared"
+ CMAKE_SHLIB_LINK_FLAGS=""
CMAKE_SHLIB_RUNTIME_FLAG=""
CMAKE_SHLIB_RUNTIME_SEP=""
;;