summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-06-28 21:45:54 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-06-28 21:45:54 (GMT)
commita7f7366abdff30b8891a2d4c94e33f4e4760c42b (patch)
tree2728b2942d3a7a8bbd62aa13c0a490a8aa9ec5b3 /Templates/configure.in
parent850d74f67f44514ab9eaa078bc44a43987e3a3fa (diff)
downloadCMake-a7f7366abdff30b8891a2d4c94e33f4e4760c42b.zip
CMake-a7f7366abdff30b8891a2d4c94e33f4e4760c42b.tar.gz
CMake-a7f7366abdff30b8891a2d4c94e33f4e4760c42b.tar.bz2
ENH: various fixes to allow bootstrap on sunos with CC
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in21
1 files changed, 12 insertions, 9 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 9237325..f75b573 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -497,14 +497,6 @@ if test $ac_cv_prog_gxx = no; then
echo "$ac_t""no" 1>&6
fi
rm -f conftest*
- echo $ac_n "checking whether ${CXX} accepts -instances=semiexplicit""... $ac_c" 1>&6
- echo 'void f(){}' > conftest.cc
- if test -z "`${CXX} -instances=static -c conftest.cc 2>&1`"; then
- echo "$ac_t""yes" 1>&6
- CMAKE_TEMPLATE_FLAGS="-instances=static"
- else
- echo "$ac_t""no" 1>&6
- fi
fi
AC_SUBST(CMAKE_TEMPLATE_FLAGS)
@@ -549,7 +541,18 @@ fi
# find make to use to build cmake, prefer gmake
AC_PATH_PROGS(RUNMAKE, gmake make)
-AC_PATH_PROGS(CMAKE_AR, ar)
+AC_PATH_PROGS(CMAKE_AR_TMP, ar)
+CMAKE_AR="$CMAKE_AR_TMP cr"
+# if on SunOS and not using gXX then use the compiler to make .a libs
+case $system in
+ SunOS-5*)
+ if test $ac_cv_prog_gxx = yes; then
+ :
+ else
+ echo "Using $CXX -xar -o for creating .a libraries"
+ CMAKE_AR="$CXX -xar -o"
+ fi
+esac
AC_SUBST(CMAKE_AR)
# generate output files.