summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBerk Geveci <berk.geveci@kitware.com>2001-10-26 21:06:46 (GMT)
committerBerk Geveci <berk.geveci@kitware.com>2001-10-26 21:06:46 (GMT)
commitd9b7df43ce24f08985728fbca6c68688a001c586 (patch)
treecfad262310cca10d93b3b4354b420a6907c6f8e7 /Templates/configure.in
parent1c5c899fd7b9e0f5214f0e30b5dc64fa2508a27c (diff)
downloadCMake-d9b7df43ce24f08985728fbca6c68688a001c586.zip
CMake-d9b7df43ce24f08985728fbca6c68688a001c586.tar.gz
CMake-d9b7df43ce24f08985728fbca6c68688a001c586.tar.bz2
added CMAKE_NO_EXPLICIT_TEMPLATE_INSTANTIATION
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 7955b2c..c74091b 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -429,6 +429,14 @@ case $system in
;;
esac
+# if running on darwin no explicit template instantiations
+case $system in
+ Darwin*)
+ CMAKE_NO_EXPLICIT_TEMPLATE_INSTANTIATION="1"
+ ;;
+esac
+AC_SUBST(CMAKE_NO_EXPLICIT_TEMPLATE_INSTANTIATION)
+
# If the user has supplied C flags for compiling shared objects, use
# those instead
if test "${SHLIB_CFLAGS}" != ""; then