summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-27 14:11:48 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-27 14:11:48 (GMT)
commit66be1686da0c63454ba085a51527e9d52c6c5268 (patch)
treea93da84c2b415475f951a2bd0283b15cb6b74044 /Templates/configure.in
parent277228e3aa92a025b3581cd0e808aaa89fd16852 (diff)
downloadCMake-66be1686da0c63454ba085a51527e9d52c6c5268.zip
CMake-66be1686da0c63454ba085a51527e9d52c6c5268.tar.gz
CMake-66be1686da0c63454ba085a51527e9d52c6c5268.tar.bz2
ENH: sgi -LANG:std
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 1063ee1..8349654 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -469,6 +469,7 @@ AC_SUBST(CMAKE_THREAD_LIBS)
CMAKE_ANSI_CFLAGS=""
+CMAKE_ANSI_CXXFLAGS=""
# on hp use -Aa for ansi
if test $ac_cv_prog_gxx = no; then
case $system in
@@ -488,7 +489,7 @@ case $system in
echo 'void f(){}' > conftest.c
if test -z "`${CC} -LANG:std -c conftest.c 2>&1`"; then
echo "$ac_t""yes" 1>&6
- CMAKE_ANSI_CFLAGS="-LANG:std"
+ CMAKE_ANSI_CXXFLAGS="-LANG:std"
else
echo "$ac_t""no" 1>&6
fi
@@ -497,6 +498,7 @@ case $system in
esac
fi
AC_SUBST(CMAKE_ANSI_CFLAGS)
+AC_SUBST(CMAKE_ANSI_CXXFLAGS)
# if we are not running g++ then we might need some other flags
# to get the templates compiled correctly