summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-07-16 14:17:35 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-07-16 14:17:35 (GMT)
commita07fa65f9ddf8865d82517127448e61a24e10112 (patch)
tree3f441ecf0774d5a85c22e433bc4824193ac08485 /Templates/configure.in
parent42e3ee8c0501e6263bedc10a6801348cee50a99f (diff)
downloadCMake-a07fa65f9ddf8865d82517127448e61a24e10112.zip
CMake-a07fa65f9ddf8865d82517127448e61a24e10112.tar.gz
CMake-a07fa65f9ddf8865d82517127448e61a24e10112.tar.bz2
ENH: add a variable for CMAKE_COMPILER_IS_GNUCXX
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index d1ec182..c648c4e 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -559,6 +559,11 @@ esac
AC_SUBST(CMAKE_AR)
AC_SUBST(CMAKE_AR_ARGS)
+CMAKE_COMPILER_IS_GNUGXX=0
+if test $ac_cv_prog_gxx = yes; then
+ CMAKE_COMPILER_IS_GNUCXX=1
+fi
+AC_SUBST(CMAKE_COMPILER_IS_GNUCXX)
# generate output files.
# create mkdir files just to make some of the directories