summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-02-14 15:02:09 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-02-14 15:02:09 (GMT)
commit2cc36654e65200fbd8c3b702cb449c95d0268a70 (patch)
treecc5e4b7c2177571b0e7138ffed6d317bdad2f9f2 /Templates/configure.in
parenta12b5b958bebd3e59520fc7eea565ca661f7f188 (diff)
downloadCMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.zip
CMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.tar.gz
CMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.tar.bz2
ENH: do not use O2 g as default flags
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index e3c4b4a..b451e2b 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -7,8 +7,21 @@ AC_SUBST(CMAKE_CONFIG_DIR)
#
# check for some programs we use
#
+
+# save the CFLAGS and CXXFLAGS specified by the user
+save_CFLAGS=$CFLAGS
+save_CXXFLAGS=$CXXFLAGS
+
AC_PROG_CC
AC_PROG_CXX
+
+
+# restore the flags specified by the user and get rid of any flags
+# found by autoconf (we do not want -02 -g by default)
+CFLAGS=$save_CFLAGS
+CXXFLAGS=$save_CXXFLAGS
+
+
AC_PROG_RANLIB
AC_PROG_INSTALL