summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-24 21:30:03 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-24 21:30:03 (GMT)
commitc308c233a0a81e22ec01974260510111850d9207 (patch)
tree4c65f5e311f8c76640922a2b9fa7b251f66e090b /Templates/configure.in
parent65ea235240401dec2b7b33ebcd620c92b849f5d0 (diff)
downloadCMake-c308c233a0a81e22ec01974260510111850d9207.zip
CMake-c308c233a0a81e22ec01974260510111850d9207.tar.gz
CMake-c308c233a0a81e22ec01974260510111850d9207.tar.bz2
ENH: more sgi -LANG stuff
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index eb5743f..92fd5e9 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -482,7 +482,18 @@ case $system in
echo "$ac_t""no" 1>&6
fi
rm -f conftest*
- ;;
+ ;;
+ IRIX-5* | IRIX-6* | IRIX64-6* | IRIX-64-6*)
+ echo $ac_n "checking whether ${CC} accepts -LANG:std""... $ac_c" 1>&6
+ echo 'void f(){}' > conftest.c
+ if test -z "`${CC} -LANG:std -c conftest.c 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ CMAKE_ANSI_CFLAGS="-LANG:std"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+ rm -f conftest*
+ ;;
esac
fi
AC_SUBST(CMAKE_ANSI_CFLAGS)