summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-18 21:57:17 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-18 21:57:17 (GMT)
commitb817ee6596f43a658c1e1499ba7da67c096df792 (patch)
tree0a83f0ba910ddc981277f313b716c2d0bcc7fbc9 /Templates/configure.in
parentce4f2718f2e56aec5ff39a70354da3368fd2dc49 (diff)
downloadCMake-b817ee6596f43a658c1e1499ba7da67c096df792.zip
CMake-b817ee6596f43a658c1e1499ba7da67c096df792.tar.gz
CMake-b817ee6596f43a658c1e1499ba7da67c096df792.tar.bz2
BUG: get the flags right
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index b2e6910..19df1f9 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -503,6 +503,7 @@ if test $ac_cv_prog_gxx = no; then
fi
AC_SUBST(CMAKE_TEMPLATE_FLAGS)
+
# check no g++ compilers to see if they have the standard
# ansi stream files (without the .h)
if test $ac_cv_prog_gxx = no; then
@@ -514,11 +515,11 @@ if test $ac_cv_prog_gxx = no; then
if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
- CMAKE_NO_STD_NAMESPACE="1"
+ CMAKE_NO_ANSI_STREAM_HEADERS="1"
echo "$ac_t""no" 1>&6
fi
fi
-AC_SUBST(CMAKE_NO_STD_NAMESPACE)
+AC_SUBST(CMAKE_NO_ANSI_STREAM_HEADERS)
# check to see if stl is in the std namespace
if test $ac_cv_prog_gxx = no; then
@@ -531,12 +532,11 @@ void foo() { std::list<int> l; }
if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
- CMAKE_NO_ANSI_STREAM_HEADERS="1"
+ AC_DEFINE(CMAKE_NO_STD_NAMESPACE)
echo "$ac_t""no" 1>&6
fi
fi
-AC_SUBST(CMAKE_NO_ANSI_STREAM_HEADERS)
-
+AC_SUBST(CMAKE_NO_STD_NAMESPACE)
# check to see if for scoping is supported
if test $ac_cv_prog_gxx = no; then