summaryrefslogtreecommitdiffstats
path: root/Tests/AliasTarget/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-08-04 13:49:04 (GMT)
committerBrad King <brad.king@kitware.com>2017-08-07 13:16:09 (GMT)
commit49640d362981e918d94ef92c7a184749bbd7473d (patch)
tree38c85f08ebeb9f843336267e49d51f009095ec38 /Tests/AliasTarget/CMakeLists.txt
parentacd462dd314c599e4d7b9231723729fdcc189bee (diff)
downloadCMake-49640d362981e918d94ef92c7a184749bbd7473d.zip
CMake-49640d362981e918d94ef92c7a184749bbd7473d.tar.gz
CMake-49640d362981e918d94ef92c7a184749bbd7473d.tar.bz2
HP-UX: Drop support for building CMake on HP-UX
CMake will soon require both C++11 and libuv to build. Neither of these works on HP-UX, so unfortunately we need to drop support for the platform until someone can get them working. Issue: #17137
Diffstat (limited to 'Tests/AliasTarget/CMakeLists.txt')
-rw-r--r--Tests/AliasTarget/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/Tests/AliasTarget/CMakeLists.txt b/Tests/AliasTarget/CMakeLists.txt
index e156420..fc70135 100644
--- a/Tests/AliasTarget/CMakeLists.txt
+++ b/Tests/AliasTarget/CMakeLists.txt
@@ -4,13 +4,6 @@ project(AliasTarget)
set(CMAKE_CXX_STANDARD 98)
-# Those versions of the HP compiler that need a flag to get proper C++98
-# template support also need a flag to use the newer C++ library.
-if (CMAKE_CXX_COMPILER_ID STREQUAL HP AND
- CMAKE_CXX98_STANDARD_COMPILE_OPTION STREQUAL "+hpxstd98")
- string(APPEND CMAKE_CXX_FLAGS " -AA")
-endif ()
-
# Clang/C2 in C++98 mode cannot properly handle some of MSVC headers
if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND
CMAKE_CXX_SIMULATE_ID STREQUAL "MSVC")