summaryrefslogtreecommitdiffstats
path: root/Tests/AliasTarget/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-11-08 12:31:25 (GMT)
committerStephen Kelly <steveire@gmail.com>2015-11-08 12:54:49 (GMT)
commit4ce9742ae33678d8fce189d172c2fffb1a43061c (patch)
treec6c5430ad37f438cb0225d620b8f63e4adcd15e5 /Tests/AliasTarget/CMakeLists.txt
parent39e830a98e81929ce95694f2f81d92ffd3f14d5b (diff)
downloadCMake-4ce9742ae33678d8fce189d172c2fffb1a43061c.zip
CMake-4ce9742ae33678d8fce189d172c2fffb1a43061c.tar.gz
CMake-4ce9742ae33678d8fce189d172c2fffb1a43061c.tar.bz2
Alias: Fix access at generate-time (#15832)
Commit c389f8bb (cmLocalGenerator: Port Find method away from GetGeneratorTarget, 2015-10-25) ported the implementation of FindGeneratorTargetToUse away from the FindTargetToUse method, but neglected to handle alias targets. The latter method has a parameter to determine whether to include alias targets in the search, but as that is only needed at configure time, this generate-time equivalent does not need the condition.
Diffstat (limited to 'Tests/AliasTarget/CMakeLists.txt')
-rw-r--r--Tests/AliasTarget/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Tests/AliasTarget/CMakeLists.txt b/Tests/AliasTarget/CMakeLists.txt
index c50b4e6..e1d8966 100644
--- a/Tests/AliasTarget/CMakeLists.txt
+++ b/Tests/AliasTarget/CMakeLists.txt
@@ -37,7 +37,9 @@ target_include_directories(bat PRIVATE "${CMAKE_CURRENT_BINARY_DIR}")
add_executable(targetgenerator targetgenerator.cpp)
add_executable(Generator::Target ALIAS targetgenerator)
-add_custom_target(usealias Generator::Target)
+add_subdirectory(subdir)
+
+add_custom_target(usealias Generator::Target $<TARGET_FILE:Sub::tgt>)
add_dependencies(bat usealias)
if (NOT TARGET Another::Alias)