summaryrefslogtreecommitdiffstats
path: root/Tests/Architecture/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-03 12:17:43 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2013-10-03 12:17:43 (GMT)
commite27523a834641fe4d9b8267db54f7c8837aca437 (patch)
treebeb6efb2c8022cf658dbb89ebafd42a6839522aa /Tests/Architecture/CMakeLists.txt
parenta9a48ff9f4e84f22d2c139ac2b0323f26d877ef2 (diff)
parenta3194ff4a70c60db4fcf7d0d9bee2139af67ec8f (diff)
downloadCMake-e27523a834641fe4d9b8267db54f7c8837aca437.zip
CMake-e27523a834641fe4d9b8267db54f7c8837aca437.tar.gz
CMake-e27523a834641fe4d9b8267db54f7c8837aca437.tar.bz2
Merge topic 'xcode-5'
a3194ff Xcode: Fix OBJECT library support for Xcode 5 (#14254) dff8d11 Xcode: Drop XCODE_DEPEND_HELPER for Xcode >= 5 1180322 Xcode: Teach Tests/BuildDepends to allow LINK_DEPENDS_NO_SHARED failure 765b46d Xcode: Fix test architecture selection for Xcode >= 5
Diffstat (limited to 'Tests/Architecture/CMakeLists.txt')
-rw-r--r--Tests/Architecture/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/Architecture/CMakeLists.txt b/Tests/Architecture/CMakeLists.txt
index 927ce3f..ea5fc0b 100644
--- a/Tests/Architecture/CMakeLists.txt
+++ b/Tests/Architecture/CMakeLists.txt
@@ -7,8 +7,8 @@ function(test_for_xcode4 result_var)
execute_process(COMMAND xcodebuild -version
OUTPUT_VARIABLE ov RESULT_VARIABLE rv
)
- if("${rv}" STREQUAL "0")
- if(ov MATCHES "^Xcode 4.[0-9].*$")
+ if("${rv}" STREQUAL "0" AND ov MATCHES "^Xcode ([0-9]+)\\.")
+ if(NOT CMAKE_MATCH_1 VERSION_LESS 4)
set(${result_var} 1 PARENT_SCOPE)
endif()
endif()