summaryrefslogtreecommitdiffstats
path: root/Tests/BuildDepends/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-05-19 14:50:11 (GMT)
committerBrad King <brad.king@kitware.com>2014-05-19 14:51:16 (GMT)
commite4114ee9e93dc899724c48802cc529efec92f547 (patch)
tree5188fac46f1d960c1fb23e1c0afc9a710c72873d /Tests/BuildDepends/CMakeLists.txt
parent7019152aa2951ba14bd89c4805a9a9bdb17e7060 (diff)
downloadCMake-e4114ee9e93dc899724c48802cc529efec92f547.zip
CMake-e4114ee9e93dc899724c48802cc529efec92f547.tar.gz
CMake-e4114ee9e93dc899724c48802cc529efec92f547.tar.bz2
Tests/BuildDepends: Make 3-second delay more robust
Use "cmake -E sleep 3" instead of execute_process with a TIMEOUT of 3. This avoids using a busy loop or depending on a timeout to kill it.
Diffstat (limited to 'Tests/BuildDepends/CMakeLists.txt')
-rw-r--r--Tests/BuildDepends/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Tests/BuildDepends/CMakeLists.txt b/Tests/BuildDepends/CMakeLists.txt
index a875f07..8df331e 100644
--- a/Tests/BuildDepends/CMakeLists.txt
+++ b/Tests/BuildDepends/CMakeLists.txt
@@ -182,8 +182,7 @@ else()
endif()
message("Waiting 3 seconds...")
-# any additional argument will cause ${bar} to wait forever
-execute_process(COMMAND ${bar} -infinite TIMEOUT 3 OUTPUT_VARIABLE out)
+execute_process(COMMAND ${CMAKE_COMMAND} -E sleep 3)
message("Modifying Project/foo.cxx")
write_file(${BuildDepends_BINARY_DIR}/Project/foo.cxx