summaryrefslogtreecommitdiffstats
path: root/Tests/BuildDepends/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-05-23 17:27:00 (GMT)
committerBrad King <brad.king@kitware.com>2007-05-23 17:27:00 (GMT)
commitc288da754a3f1221ca4ebfd9c9efb8c935d499d6 (patch)
tree998d24826c3e2e32158b8255d5c1c8715139761c /Tests/BuildDepends/CMakeLists.txt
parent702d785c9ae49015a770530a9c5f27e7bfaff716 (diff)
downloadCMake-c288da754a3f1221ca4ebfd9c9efb8c935d499d6.zip
CMake-c288da754a3f1221ca4ebfd9c9efb8c935d499d6.tar.gz
CMake-c288da754a3f1221ca4ebfd9c9efb8c935d499d6.tar.bz2
BUG: Target names in the COMMAND part of a custom command should not create a file-level dependency that forces the command to rerun when the executable target rebuilds, but the target-level dependency should still be created. Target names in a DEPENDS should do both a target-level and file-level dependency. Updated the BuildDepends test to check that this works.
Diffstat (limited to 'Tests/BuildDepends/CMakeLists.txt')
-rw-r--r--Tests/BuildDepends/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/BuildDepends/CMakeLists.txt b/Tests/BuildDepends/CMakeLists.txt
index 80793bc..3a4ba26 100644
--- a/Tests/BuildDepends/CMakeLists.txt
+++ b/Tests/BuildDepends/CMakeLists.txt
@@ -60,5 +60,5 @@ message("${out}")
if("${out}" STREQUAL "foo changed ")
message("Worked!")
else("${out}" STREQUAL "foo changed ")
- message(SEND_ERROR "Program did not rebuild with changed file")
+ message(SEND_ERROR "Project did not rebuild properly!")
endif("${out}" STREQUAL "foo changed ")