summaryrefslogtreecommitdiffstats
path: root/Tests/BuildDepends/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2011-11-15 04:39:52 (GMT)
committerPeter Collingbourne <peter@pcc.me.uk>2012-02-02 23:36:49 (GMT)
commit7eb8d9036c73784f14da9d8381023c1e26df1275 (patch)
tree6d6be598e8850d3bc95a9247cef05a24cfa27de1 /Tests/BuildDepends/CMakeLists.txt
parent4468edf12b0b87e32768fcdce7abd30afddcad7b (diff)
downloadCMake-7eb8d9036c73784f14da9d8381023c1e26df1275.zip
CMake-7eb8d9036c73784f14da9d8381023c1e26df1275.tar.gz
CMake-7eb8d9036c73784f14da9d8381023c1e26df1275.tar.bz2
Provide dependency file flags to generator
Causes compiler modules (currently only GNU) to set a CMAKE_DEPFILE_FLAGS_${lang} variable, which communicates to the generator the flags required to cause the compiler to create dependency files.
Diffstat (limited to 'Tests/BuildDepends/CMakeLists.txt')
-rw-r--r--Tests/BuildDepends/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/BuildDepends/CMakeLists.txt b/Tests/BuildDepends/CMakeLists.txt
index 31392b5..aa32d67 100644
--- a/Tests/BuildDepends/CMakeLists.txt
+++ b/Tests/BuildDepends/CMakeLists.txt
@@ -40,6 +40,8 @@ if("${CMAKE_GENERATOR}" MATCHES "Make")
endif()
list(APPEND _cmake_options "-DTEST_LINK_DEPENDS=${TEST_LINK_DEPENDS}")
+list(APPEND _cmake_options "-DCMAKE_FORCE_DEPFILES=1")
+
file(MAKE_DIRECTORY ${BuildDepends_BINARY_DIR}/Project)
message("Creating Project/foo.cxx")
write_file(${BuildDepends_BINARY_DIR}/Project/foo.cxx