summaryrefslogtreecommitdiffstats
path: root/Tests/BuildDepends/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2009-10-28 16:17:18 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2009-10-28 16:17:18 (GMT)
commitb4ae8bad4b8e7810a44e2f77363de3009260a473 (patch)
tree7dd8a97d409c6339948ac4b3e0eda77cd9b7384e /Tests/BuildDepends/CMakeLists.txt
parentebd0c2d3771835a1317c1fd70eafd3ebf2135b01 (diff)
downloadCMake-b4ae8bad4b8e7810a44e2f77363de3009260a473.zip
CMake-b4ae8bad4b8e7810a44e2f77363de3009260a473.tar.gz
CMake-b4ae8bad4b8e7810a44e2f77363de3009260a473.tar.bz2
RC 4 merge
Diffstat (limited to 'Tests/BuildDepends/CMakeLists.txt')
-rw-r--r--Tests/BuildDepends/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/Tests/BuildDepends/CMakeLists.txt b/Tests/BuildDepends/CMakeLists.txt
index d8f8360..8714640 100644
--- a/Tests/BuildDepends/CMakeLists.txt
+++ b/Tests/BuildDepends/CMakeLists.txt
@@ -28,6 +28,12 @@ function(help_xcode_depends)
endif(HELP_XCODE)
endfunction(help_xcode_depends)
+# The Intel compiler causes the MSVC linker to crash during
+# incremental linking, so avoid the /INCREMENTAL:YES flag.
+if(WIN32 AND "${CMAKE_CXX_COMPILER_ID}" MATCHES "Intel")
+ set(_cmake_options "-DCMAKE_EXE_LINKER_FLAGS=")
+endif()
+
file(MAKE_DIRECTORY ${BuildDepends_BINARY_DIR}/Project)
message("Creating Project/foo.cxx")
write_file(${BuildDepends_BINARY_DIR}/Project/foo.cxx
@@ -49,6 +55,7 @@ try_compile(RESULT
${BuildDepends_BINARY_DIR}/Project
${BuildDepends_SOURCE_DIR}/Project
testRebuild
+ CMAKE_FLAGS ${_cmake_options}
OUTPUT_VARIABLE OUTPUT)
if(HELP_XCODE)
try_compile(RESULT
@@ -63,8 +70,9 @@ if(HELP_XCODE)
OUTPUT_VARIABLE OUTPUT)
endif(HELP_XCODE)
+message("Output from first build:\n${OUTPUT}")
if(NOT RESULT)
- message(SEND_ERROR "Could not build test project: ${OUTPUT}")
+ message(SEND_ERROR "Could not build test project (1)!")
endif(NOT RESULT)
set(bar ${BuildDepends_BINARY_DIR}/Project/bar${CMAKE_EXECUTABLE_SUFFIX})
@@ -130,6 +138,7 @@ try_compile(RESULT
${BuildDepends_BINARY_DIR}/Project
${BuildDepends_SOURCE_DIR}/Project
testRebuild
+ CMAKE_FLAGS ${_cmake_options}
OUTPUT_VARIABLE OUTPUT)
# Xcode is in serious need of help here
@@ -146,8 +155,9 @@ if(HELP_XCODE)
OUTPUT_VARIABLE OUTPUT)
endif(HELP_XCODE)
+message("Output from second build:\n${OUTPUT}")
if(NOT RESULT)
- message(SEND_ERROR "Could not build test project: ${OUTPUT}")
+ message(SEND_ERROR "Could not build test project (2)!")
endif(NOT RESULT)
if(EXISTS
"${BuildDepends_BINARY_DIR}/Project/Debug/bar${CMAKE_EXECUTABLE_SUFFIX}" )