summaryrefslogtreecommitdiffstats
path: root/Tests/BundleTest/BundleSubDir/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-08-14 12:31:45 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-08-14 12:31:45 (GMT)
commitcd3bd23266a4a6c00595134a17a8bdaea9e28af5 (patch)
tree515fcf4fdee211067497339acb52de321640c4fc /Tests/BundleTest/BundleSubDir/CMakeLists.txt
parent9acb4f118cd9a52aaa66897b1c0cd11dace3851c (diff)
parent68bc863d5bd64f3e893722e403d4fd56bd2e175a (diff)
downloadCMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.zip
CMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.tar.gz
CMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.tar.bz2
Merge topic 'cleanup-style'
68bc863 Merge branch 'master' into cleanup-style a05eba5 CMakeVersion.bash: Update sed expression for lower-case 'set' 3c0488d Fix WarnUnusedUnusedViaUnset test pass/fail regex 6c2c483 Remove trailing TAB from NSIS.template.in 9db3116 Remove CMake-language block-end command arguments 77543bd Convert CMake-language commands to lower case 7bbaa42 Remove trailing whitespace from most CMake and C/C++ code be9db98 Merge topic 'watcom-compiler-version' af42ae4 Watcom: Simplify compiler version detection (#11866)
Diffstat (limited to 'Tests/BundleTest/BundleSubDir/CMakeLists.txt')
-rw-r--r--Tests/BundleTest/BundleSubDir/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/BundleTest/BundleSubDir/CMakeLists.txt b/Tests/BundleTest/BundleSubDir/CMakeLists.txt
index 322b2a7..1921ce0 100644
--- a/Tests/BundleTest/BundleSubDir/CMakeLists.txt
+++ b/Tests/BundleTest/BundleSubDir/CMakeLists.txt
@@ -1,36 +1,36 @@
-ADD_CUSTOM_COMMAND(
+add_custom_command(
OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
COMMAND /bin/cp
ARGS "${BundleTest_SOURCE_DIR}/randomResourceFile.plist.in"
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist")
-SET_SOURCE_FILES_PROPERTIES(
+set_source_files_properties(
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
PROPERTIES
MACOSX_PACKAGE_LOCATION Resources
)
-SET_SOURCE_FILES_PROPERTIES(
+set_source_files_properties(
"${BundleTest_SOURCE_DIR}/SomeRandomFile.txt"
"${BundleTest_SOURCE_DIR}/../../ChangeLog.txt"
PROPERTIES
MACOSX_PACKAGE_LOCATION MacOS
)
-ADD_EXECUTABLE(SecondBundle
+add_executable(SecondBundle
MACOSX_BUNDLE
"${BundleTest_SOURCE_DIR}/BundleTest.cxx"
"${BundleTest_SOURCE_DIR}/SomeRandomFile.txt"
"${BundleTest_SOURCE_DIR}/../../ChangeLog.txt"
"${CMAKE_CURRENT_BINARY_DIR}/randomResourceFile.plist"
)
-TARGET_LINK_LIBRARIES(SecondBundle BundleTestLib)
+target_link_libraries(SecondBundle BundleTestLib)
# Test bundle installation.
-INSTALL(TARGETS SecondBundle DESTINATION Applications)
+install(TARGETS SecondBundle DESTINATION Applications)
# Test whether bundles respect the output name. Since the library is
# installed into a location that uses this output name this will fail if the
# bundle does not respect the name. Also the executable will not be found by
# the test driver if this does not work.
-SET_TARGET_PROPERTIES(SecondBundle PROPERTIES OUTPUT_NAME SecondBundleExe)
+set_target_properties(SecondBundle PROPERTIES OUTPUT_NAME SecondBundleExe)