summaryrefslogtreecommitdiffstats
path: root/Tests/BundleTest/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2007-08-24 17:30:41 (GMT)
committerDavid Cole <david.cole@kitware.com>2007-08-24 17:30:41 (GMT)
commit9a4e7ea742e7ff8e1110f3fe55e98340cb309aef (patch)
tree1de0114f0f0f2fc3ac8ac9a2d92770a6e08ea281 /Tests/BundleTest/CMakeLists.txt
parent6d508a3094c31910728b24e13ceebbc3070b5e04 (diff)
downloadCMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.zip
CMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.tar.gz
CMake-9a4e7ea742e7ff8e1110f3fe55e98340cb309aef.tar.bz2
ENH: Add InstallNameFixupPath to support installing built frameworks on the Mac. Change Application to Applications in the BundleTest. Also correct small typo (tcl->Tcl) noted in bug 4572.
Diffstat (limited to 'Tests/BundleTest/CMakeLists.txt')
-rw-r--r--Tests/BundleTest/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/Tests/BundleTest/CMakeLists.txt b/Tests/BundleTest/CMakeLists.txt
index ff9626f..2eec9ea 100644
--- a/Tests/BundleTest/CMakeLists.txt
+++ b/Tests/BundleTest/CMakeLists.txt
@@ -36,9 +36,9 @@ ADD_EXECUTABLE(BundleTest
TARGET_LINK_LIBRARIES(BundleTest BundleTestLib)
# Test bundle installation.
-#INSTALL(TARGETS BundleTestLib DESTINATION Application/BundleTestExe.app/Contents/Plugins)
-INSTALL(TARGETS BundleTestLib DESTINATION Application/SecondBundleExe.app/Contents/Plugins)
-INSTALL(TARGETS BundleTest DESTINATION Application)
+#INSTALL(TARGETS BundleTestLib DESTINATION Applications/BundleTestExe.app/Contents/Plugins)
+INSTALL(TARGETS BundleTestLib DESTINATION Applications/SecondBundleExe.app/Contents/Plugins)
+INSTALL(TARGETS BundleTest DESTINATION Applications)
# Test whether bundles respect the output name. Since the library is
# installed into a location that uses this output name this will fail if the
@@ -59,7 +59,7 @@ INCLUDE(CPack)
# test the framework find stuff
IF(EXISTS /usr/lib/libtcl.dylib
- AND EXISTS /System/Library/Frameworks/tcl.framework)
+ AND EXISTS /System/Library/Frameworks/Tcl.framework)
SET(TCL NOTFOUND)
FIND_LIBRARY(TCL tcl)
MESSAGE("frame: ${TCL}")
@@ -87,6 +87,6 @@ IF(EXISTS /usr/lib/libtcl.dylib
ENDIF(NOT "${TCL}" MATCHES .framework)
MESSAGE("frame: ${TCL}")
ENDIF(EXISTS /usr/lib/libtcl.dylib
- AND EXISTS /System/Library/Frameworks/tcl.framework)
+ AND EXISTS /System/Library/Frameworks/Tcl.framework)
SUBDIRS(BundleSubDir)