summaryrefslogtreecommitdiffstats
path: root/Tests/CFBundleTest/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-09-03 13:41:22 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-09-03 13:43:32 (GMT)
commitaa3465fcd2d792880fd7e2a6754a283d6df66531 (patch)
tree8fe572267071df883b88aa757344d9e137ac5928 /Tests/CFBundleTest/CMakeLists.txt
parent1f7bd0032253296413770567a90a0a88b6cccb34 (diff)
parente29a92f5259def88bda0c292f591fda68c0e064e (diff)
downloadCMake-aa3465fcd2d792880fd7e2a6754a283d6df66531.zip
CMake-aa3465fcd2d792880fd7e2a6754a283d6df66531.tar.gz
CMake-aa3465fcd2d792880fd7e2a6754a283d6df66531.tar.bz2
Merge topic 'xcode11-bundles'
e29a92f525 Xcode: Make BundleTests compatible with Xcode 11 Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3767
Diffstat (limited to 'Tests/CFBundleTest/CMakeLists.txt')
-rw-r--r--Tests/CFBundleTest/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CFBundleTest/CMakeLists.txt b/Tests/CFBundleTest/CMakeLists.txt
index 0fe6bb7..b2b1b73 100644
--- a/Tests/CFBundleTest/CMakeLists.txt
+++ b/Tests/CFBundleTest/CMakeLists.txt
@@ -50,6 +50,8 @@ set_source_files_properties(
set_target_properties(CFBundleTest PROPERTIES
BUNDLE 1
BUNDLE_EXTENSION plugin
+ XCODE_ATTRIBUTE_CODE_SIGN_IDENTITY ""
+ XCODE_ATTRIBUTE_CODE_SIGNING_REQUIRED "NO"
XCODE_ATTRIBUTE_MACH_O_TYPE mh_bundle
XCODE_ATTRIBUTE_INFOPLIST_FILE ${CMAKE_CURRENT_BINARY_DIR}/Info.plist
MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_BINARY_DIR}/Info.plist