summaryrefslogtreecommitdiffstats
path: root/Tests/CFBundleTest/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2013-11-06 13:41:54 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2013-11-06 13:42:44 (GMT)
commita5aadcd46d3cd8cbf5bc4855a721a48d9269ab6e (patch)
tree32314060773a961ce0f035b642b59011ad24c972 /Tests/CFBundleTest/CMakeLists.txt
parent4d6b88d44b35896ec6a2adecc19b5d73c95539c6 (diff)
downloadCMake-a5aadcd46d3cd8cbf5bc4855a721a48d9269ab6e.zip
CMake-a5aadcd46d3cd8cbf5bc4855a721a48d9269ab6e.tar.gz
CMake-a5aadcd46d3cd8cbf5bc4855a721a48d9269ab6e.tar.bz2
CFBundle test: Add isysroot argument when calling Rez.
Diffstat (limited to 'Tests/CFBundleTest/CMakeLists.txt')
-rw-r--r--Tests/CFBundleTest/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Tests/CFBundleTest/CMakeLists.txt b/Tests/CFBundleTest/CMakeLists.txt
index bf9771c..5cda527 100644
--- a/Tests/CFBundleTest/CMakeLists.txt
+++ b/Tests/CFBundleTest/CMakeLists.txt
@@ -30,8 +30,14 @@ if(NOT RC_COMPILER)
message(FATAL_ERROR "could not find Rez to build resources from .r file...")
endif()
+set(sysroot)
+if(CMAKE_OSX_SYSROOT)
+ set(sysroot -isysroot ${CMAKE_OSX_SYSROOT})
+endif()
+
execute_process(COMMAND
- ${RC_COMPILER} ${RCFILES} -useDF -o ${CMAKE_CURRENT_BINARY_DIR}/Localized.rsrc
+ ${RC_COMPILER} ${sysroot} ${RCFILES} -useDF
+ -o ${CMAKE_CURRENT_BINARY_DIR}/Localized.rsrc
)
set_source_files_properties(