summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-08 16:44:50 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-08 16:44:50 (GMT)
commit5872cc7c1f0b41e7b9cfe7060ef88bc69daf8219 (patch)
tree91688b017d4431e5ed43352d086738b935fc9cd8 /Tests/CMakeLib/CMakeLists.txt
parentd4ada9d0d540ab2dc2a9747315c5afda5887950f (diff)
downloadCMake-5872cc7c1f0b41e7b9cfe7060ef88bc69daf8219.zip
CMake-5872cc7c1f0b41e7b9cfe7060ef88bc69daf8219.tar.gz
CMake-5872cc7c1f0b41e7b9cfe7060ef88bc69daf8219.tar.bz2
Create CMakeLib test driver and test cmXMLParser
We create a new CMakeLibTests driver executable in which to writes unit tests for CMakeLib. Our first test is a smoke-test of cmXMLParser.
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
new file mode 100644
index 0000000..37bc09f
--- /dev/null
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMake_BINARY_DIR}/Source
+ ${CMake_SOURCE_DIR}/Source
+ )
+
+set(CMakeLib_TESTS
+ testXMLParser
+ )
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/testXMLParser.h.in
+ ${CMAKE_CURRENT_BINARY_DIR}/testXMLParser.h @ONLY)
+
+create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
+add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})
+target_link_libraries(CMakeLibTests CMakeLib)
+
+foreach(test ${CMakeLib_TESTS})
+ add_test(CMakeLib.${test} CMakeLibTests ${test})
+endforeach()