summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorDāvis Mosāns <davispuh@gmail.com>2016-11-23 12:11:40 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-30 14:06:51 (GMT)
commit2ed473b3b8e28485e6a14a49c7e0e4133eb02eee (patch)
tree1343f0e826693c923074102e588f90f0678e3cc5 /Tests/CMakeLib/CMakeLists.txt
parent076aef8e45a91e83f9a7d879712fd70778d67c92 (diff)
downloadCMake-2ed473b3b8e28485e6a14a49c7e0e4133eb02eee.zip
CMake-2ed473b3b8e28485e6a14a49c7e0e4133eb02eee.tar.gz
CMake-2ed473b3b8e28485e6a14a49c7e0e4133eb02eee.tar.bz2
execute_process: Add ENCODING option for Windows child process output
Different applications can use different output encodings.
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index 405917a..d680205 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -31,6 +31,9 @@ create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})
target_link_libraries(CMakeLibTests CMakeLib)
+add_executable(testEncoding testEncoding.cxx)
+target_link_libraries(testEncoding cmsys)
+
# Xcode 2.x forgets to create the output directory before linking
# the individual architectures.
if(CMAKE_OSX_ARCHITECTURES AND XCODE