summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2022-08-21 00:48:36 (GMT)
committerBrad King <brad.king@kitware.com>2022-09-22 13:24:47 (GMT)
commit0aed435b351577681a7cbbd8c542fbe998d1717d (patch)
tree49eea98dfea8fa493bf27d70b2b0fafc828277d2 /Tests/CMakeLib/CMakeLists.txt
parenta67c9f975686d4036a31597d535982c31df97ebe (diff)
downloadCMake-0aed435b351577681a7cbbd8c542fbe998d1717d.zip
CMake-0aed435b351577681a7cbbd8c542fbe998d1717d.tar.gz
CMake-0aed435b351577681a7cbbd8c542fbe998d1717d.tar.bz2
Build: Simplify `configure_file()` calls
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index 1d45162..612d4b4 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -47,12 +47,10 @@ if(WIN32)
list(APPEND CMakeLib_TESTS
testVisualStudioSlnParser.cxx
)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/testVisualStudioSlnParser.h.in
- ${CMAKE_CURRENT_BINARY_DIR}/testVisualStudioSlnParser.h @ONLY)
+ configure_file(testVisualStudioSlnParser.h.in testVisualStudioSlnParser.h @ONLY)
endif()
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/testXMLParser.h.in
- ${CMAKE_CURRENT_BINARY_DIR}/testXMLParser.h @ONLY)
+configure_file(testXMLParser.h.in testXMLParser.h @ONLY)
create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})