summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-04-30 15:29:30 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2019-05-07 17:40:06 (GMT)
commit26025d6e106ffd4cd777fdc3a4343b33c8554c15 (patch)
treef40c983a734557f9137fa775fd051437079c89e4 /Tests/CMakeLib/CMakeLists.txt
parent6b04d1cdc281b9b0dee5f59394a1c41d8b96c4a1 (diff)
downloadCMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.zip
CMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.tar.gz
CMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.tar.bz2
cmUVProcessChain: Add cmUVProcessChain
This class is ultimately intended as a replacement for cmsys::Process. It spawns a series of processes using libuv, piping the output of each command into the next. Note: input support has not yet been implemented because write support has not yet been implemented on cmUVStreambuf.
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index e04bba2..a25f25a 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -15,11 +15,15 @@ set(CMakeLib_TESTS
testXMLParser.cxx
testXMLSafe.cxx
testFindPackageCommand.cxx
+ testUVProcessChain.cxx
testUVRAII.cxx
testUVStreambuf.cxx
)
+add_executable(testUVProcessChainHelper testUVProcessChainHelper.cxx)
+
set(testRST_ARGS ${CMAKE_CURRENT_SOURCE_DIR})
+set(testUVProcessChain_ARGS $<TARGET_FILE:testUVProcessChainHelper>)
set(testUVStreambuf_ARGS $<TARGET_FILE:cmake>)
if(WIN32)