summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-04-25 17:16:01 (GMT)
committerBrad King <brad.king@kitware.com>2011-05-16 14:42:10 (GMT)
commit8346a28a0a6587382a30d06a998ae83caa574f4b (patch)
tree2420195b95df0d2691b830585ccdbd0b9153de1e /Tests/CMakeLib/CMakeLists.txt
parent0e6b05fcba61a1b113b841dd2b3e1e5060866d0e (diff)
downloadCMake-8346a28a0a6587382a30d06a998ae83caa574f4b.zip
CMake-8346a28a0a6587382a30d06a998ae83caa574f4b.tar.gz
CMake-8346a28a0a6587382a30d06a998ae83caa574f4b.tar.bz2
Only offer the compile command output feature on unix systems
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index 7815545..41bf034 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -31,5 +31,7 @@ foreach(test ${CMakeLib_TESTS})
add_test(CMakeLib.${test} CMakeLibTests ${test})
endforeach()
-ADD_EXECUTABLE(runcompilecommands run_compile_commands.cxx)
-TARGET_LINK_LIBRARIES(runcompilecommands CMakeLib)
+if(TEST_CompileCommandOutput)
+ add_executable(runcompilecommands run_compile_commands.cxx)
+ target_link_libraries(runcompilecommands CMakeLib)
+endif()