summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-03-31 23:55:00 (GMT)
committerBrad King <brad.king@kitware.com>2011-04-25 17:27:59 (GMT)
commit0e6b05fcba61a1b113b841dd2b3e1e5060866d0e (patch)
tree7c7a2237420f7c6692e7d9d752373d1ceb4ef7cb /Tests/CMakeLib/CMakeLists.txt
parent5674844de4b74d0b66cfc6b8237e631702c43637 (diff)
downloadCMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.zip
CMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.tar.gz
CMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.tar.bz2
Adds a test for the compile command line output.
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index bda2fa5..7815545 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -30,3 +30,6 @@ endif()
foreach(test ${CMakeLib_TESTS})
add_test(CMakeLib.${test} CMakeLibTests ${test})
endforeach()
+
+ADD_EXECUTABLE(runcompilecommands run_compile_commands.cxx)
+TARGET_LINK_LIBRARIES(runcompilecommands CMakeLib)