summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-06-13 15:02:27 (GMT)
committerDavid Cole <david.cole@kitware.com>2010-06-13 15:02:27 (GMT)
commit199e7f2f331aded0c7cb3f666bd2c996e2b4aa5e (patch)
tree85a80af59237299195fae79d46a25cb60b7fc3e3 /Tests/CMakeLists.txt
parent8d29fa46abba732410147aa80cbcc58ceb265835 (diff)
downloadCMake-199e7f2f331aded0c7cb3f666bd2c996e2b4aa5e.zip
CMake-199e7f2f331aded0c7cb3f666bd2c996e2b4aa5e.tar.gz
CMake-199e7f2f331aded0c7cb3f666bd2c996e2b4aa5e.tar.bz2
Remove CTestTest3.
At this point, CTestTest3 causes more problems than it's worth. It uses CVS to grab a remote (over the network) copy of kwsys code for testing. This causes some sort of problem nearly every night on the nightly CMake dashboards. Worse: it causes problems on different machines on different nights, then the next day, it's fine again. So: remove this test and monitor the coverage. If we lose a significant portion of code coverage, I will revert this commit and re-activate the test. However, if we do not lose a significant portion of code coverage, I will remove the code for the test as well as removing it from the CMakeLists.txt file. Brad King and I discussed this over the last few weeks, and we both think we have sufficient coverage of all the checkout and update code in other locally (non-network) based tests. On the other hand, even if we do take a mild hit on coverage temporarily, it should be relatively easy to increase our coverage again by adding bits to those other locally based tests.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 1b8f4f3..0aaa7fb 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1470,13 +1470,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--output-log "${CMake_BINARY_DIR}/Tests/CTestTest2/testOutput.log"
)
- CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CTestTest3/test.cmake.in"
- "${CMake_BINARY_DIR}/Tests/CTestTest3/test.cmake" @ONLY ESCAPE_QUOTES)
- ADD_TEST(CTestTest3 ${CMAKE_CTEST_COMMAND}
- -S "${CMake_BINARY_DIR}/Tests/CTestTest3/test.cmake" -V
- --output-log "${CMake_BINARY_DIR}/Tests/CTestTest3/testOutput.log"
- )
-
# these tests take a long time, make sure they have it
# if timeouts have not already been set
GET_TEST_PROPERTY(CTestTest TIMEOUT PREVIOUS_TIMEOUT)
@@ -1490,12 +1483,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
SET_TESTS_PROPERTIES ( CTestTest2
PROPERTIES TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
ENDIF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
-
- GET_TEST_PROPERTY(CTestTest3 TIMEOUT PREVIOUS_TIMEOUT)
- IF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
- SET_TESTS_PROPERTIES ( CTestTest3
- PROPERTIES TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
- ENDIF ("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
ENDIF (CTEST_TEST_CTEST AND CMAKE_RUN_LONG_TESTS AND CMAKE_TESTS_CDASH_SERVER)
IF(NOT DEFINED CTEST_RUN_CTestSubmitLargeOutput)