summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2011-06-02 15:09:14 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2011-06-02 15:09:14 (GMT)
commit41f962a2cb239616e75f5de12d8987609dc4cde6 (patch)
tree2de351b8900943b54abedf07456262e67ea3de8d /Tests/CMakeLists.txt
parente17135e882188145e04c2ff455fad01273fdb375 (diff)
downloadCMake-41f962a2cb239616e75f5de12d8987609dc4cde6.zip
CMake-41f962a2cb239616e75f5de12d8987609dc4cde6.tar.gz
CMake-41f962a2cb239616e75f5de12d8987609dc4cde6.tar.bz2
Revert "BundleUtilities: Run test on Windows if either MSVC or dumpbin was found."
This reverts commit f3de459cec78eac3a7081379b6ee9c6cde36bb60. There are some platforms without MSVC where this test doesn't work well. We can look into these later.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index be0b3f9..d840b96 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -195,9 +195,7 @@ IF(BUILD_TESTING)
# run test for BundleUtilities on supported platforms/compilers
- find_program(DUMPBIN_EXECUTABLE NAMES dumpbin)
- mark_as_advanced(DUMPBIN_EXECUTABLE)
- if(MSVC OR DUMPBIN_EXECUTABLE OR
+ if(MSVC OR
CMAKE_SYSTEM_NAME MATCHES "Linux" OR
CMAKE_SYSTEM_NAME MATCHES "Darwin")
ADD_TEST(BundleUtilities ${CMAKE_CTEST_COMMAND}
@@ -209,7 +207,7 @@ IF(BUILD_TESTING)
--build-project BundleUtilities
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleUtilities")
- endif(MSVC OR DUMPBIN_EXECUTABLE OR
+ endif(MSVC OR
CMAKE_SYSTEM_NAME MATCHES "Linux" OR
CMAKE_SYSTEM_NAME MATCHES "Darwin")