summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-02-22 19:29:49 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-02-22 19:29:49 (GMT)
commit70bd240e6ce6f155e70a1443a42202ba343c1def (patch)
tree339e0a7e8f5b1b40f11722a884372d3c1511d010 /Tests/CMakeLists.txt
parent73bbef36d03cce70c7a3c29845d545afc67d81b8 (diff)
parent42b26ee5db46d8f8ee5b79e234fd212d61e5b3a3 (diff)
downloadCMake-70bd240e6ce6f155e70a1443a42202ba343c1def.zip
CMake-70bd240e6ce6f155e70a1443a42202ba343c1def.tar.gz
CMake-70bd240e6ce6f155e70a1443a42202ba343c1def.tar.bz2
Merge topic 'increase-ep-test-timeout'
42b26ee ExternalProject Test: Increase test timeout value
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2c11919..09854e0 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -815,11 +815,8 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--test-command ${CMAKE_CTEST_COMMAND} -V
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/ExternalProject")
- # The ExternalProject test takes 900 seconds on some machines!
- GET_TEST_PROPERTY(ExternalProject TIMEOUT PREVIOUS_TIMEOUT)
- IF("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
- SET_TESTS_PROPERTIES(ExternalProject PROPERTIES TIMEOUT 1000)
- ENDIF("${PREVIOUS_TIMEOUT}" MATCHES NOTFOUND)
+ SET_TESTS_PROPERTIES(ExternalProject PROPERTIES
+ TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
# do each of the tutorial steps
FOREACH(STP RANGE 1 7)