summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-10-08 19:09:24 (GMT)
committerDavid Cole <david.cole@kitware.com>2010-10-08 19:09:24 (GMT)
commitc81ad34e85fcc18fe8095b01e3b06d2cf1005155 (patch)
tree206681731c6d97003096e0b60469a1bd56647d0b /Tests/CMakeLists.txt
parent942ace83935fdb3272e026f21c56a6682b78d6de (diff)
downloadCMake-c81ad34e85fcc18fe8095b01e3b06d2cf1005155.zip
CMake-c81ad34e85fcc18fe8095b01e3b06d2cf1005155.tar.gz
CMake-c81ad34e85fcc18fe8095b01e3b06d2cf1005155.tar.bz2
Add a contract test for building the CSE.
To activate the CSE contract test on a given Linux machine's CMake dashboard, put CMAKE_CONTRACT_PROJECTS:STRING=cse-snapshot in the CMake dashboard's initial cache. The chosen snapshot does not generate subproject dependency info right now. That code was in a previous revision in the CSE's svn repo that apparently has not been merged into the present cse git repository master branch. After that is fixed up in the cse repo, we can update the tag here so that the snapshot built here can run a sub-project based dashboard script. For now, it runs as one big build step, building 'all'.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 895cb2a..ed12c65 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -21,7 +21,11 @@ IF(DEFINED ENV{HOME} AND NOT CTEST_NO_TEST_HOME)
FILE(MAKE_DIRECTORY "${TEST_HOME}")
FILE(WRITE "${TEST_HOME}/.cvspass" ":pserver:anoncvs@www.cmake.org:/cvsroot/KWSys A\n")
SET(TEST_HOME_ENV_CODE "# Fake a user home directory to avoid polluting the real one.
-SET(ENV{HOME} \"${TEST_HOME}\")")
+# But provide original ENV{HOME} value in ENV{CTEST_REAL_HOME} for tests that
+# need access to the real HOME directory.
+SET(ENV{CTEST_REAL_HOME} \"$ENV{HOME}\")
+SET(ENV{HOME} \"${TEST_HOME}\")
+")
ENDIF()
# Choose a default configuration for CTest tests.