summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-06-03 21:47:48 (GMT)
committerDavid Cole <david.cole@kitware.com>2010-06-03 21:47:48 (GMT)
commitf6909a69ece83851dd9c08a17e08b6c4fb34f308 (patch)
tree758761e9f25cf7767a96e9b8c58d0442004f63c8 /Tests/CMakeLists.txt
parentc15ed3294c68cc819d9471c4ea41dc3d2a95aadd (diff)
downloadCMake-f6909a69ece83851dd9c08a17e08b6c4fb34f308.zip
CMake-f6909a69ece83851dd9c08a17e08b6c4fb34f308.tar.gz
CMake-f6909a69ece83851dd9c08a17e08b6c4fb34f308.tar.bz2
Use the long test timeout value for SubmitLargeOutput.
Hopefully this will be a large enough value to get the large output test to pass on the still exceedingly slow dash19.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 330cf9f..e0fc094 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1493,6 +1493,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
#
SET_TESTS_PROPERTIES(CTestSubmitLargeOutput PROPERTIES
PASS_REGULAR_EXPRESSION "Errors occurred during submission")
+
+ # Give this test plenty of time to run on slower machines:
+ #
+ SET_TESTS_PROPERTIES(CTestSubmitLargeOutput PROPERTIES
+ TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
ENDIF(CTEST_RUN_CTestSubmitLargeOutput)
IF (CMAKE_RUN_LONG_TESTS AND TEST_KDE4_STABLE_BRANCH)