summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-08-07 14:41:06 (GMT)
committerBrad King <brad.king@kitware.com>2013-08-07 14:41:06 (GMT)
commitcd345aa77ded14ab729b11e1ce3ecb709d59b6eb (patch)
tree11464e01a9ad90c3d54d2330f7b6667148391187 /Tests/CMakeLists.txt
parent7c9f0c664f5782c09c686b8e51fe50245463914b (diff)
downloadCMake-cd345aa77ded14ab729b11e1ce3ecb709d59b6eb.zip
CMake-cd345aa77ded14ab729b11e1ce3ecb709d59b6eb.tar.gz
CMake-cd345aa77ded14ab729b11e1ce3ecb709d59b6eb.tar.bz2
Skip CTestLimitDashJ test on Borland
The Borland-built CTest binary has trouble running many instances of itself in parallel, making the test unreliable. No particular recent change appears to be the culprit and the failure is not reliably reproducible. Just silence the failure for now by skipping the test.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index dc8d869..9c3ed59 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2056,9 +2056,11 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--output-log "${CMake_BINARY_DIR}/Tests/CTestTestParallel/testOutput.log"
)
- set(CTestLimitDashJ_EXTRA_OPTIONS --force-new-ctest-process)
- add_test_macro(CTestLimitDashJ ${CMAKE_CTEST_COMMAND} -j 4
- --output-on-failure -C "\${CTestTest_CONFIG}")
+ if(NOT BORLAND)
+ set(CTestLimitDashJ_EXTRA_OPTIONS --force-new-ctest-process)
+ add_test_macro(CTestLimitDashJ ${CMAKE_CTEST_COMMAND} -j 4
+ --output-on-failure -C "\${CTestTest_CONFIG}")
+ endif()
add_test(CTestTestPrintLabels ${CMAKE_CTEST_COMMAND} --print-labels)
set_tests_properties(CTestTestPrintLabels PROPERTIES LABELS "Label1;Label2")