summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-06-07 18:06:09 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2011-06-07 18:06:09 (GMT)
commit40792a1a15f1ee3c0582486aac9182f8eaa1b316 (patch)
tree6f8dd3136a768559da114b04c00b40bc81ef6d72 /Tests/CMakeLists.txt
parent43d3048582e34a84cc061fddeb3e7967a2c7a576 (diff)
parent51e16c05f7c4e70d8bbf97a13243b1f1cfffa2d7 (diff)
downloadCMake-40792a1a15f1ee3c0582486aac9182f8eaa1b316.zip
CMake-40792a1a15f1ee3c0582486aac9182f8eaa1b316.tar.gz
CMake-40792a1a15f1ee3c0582486aac9182f8eaa1b316.tar.bz2
Merge topic 'fix-12034-fixup-bundle-with-non-dotapp-exe'
51e16c0 BundleUtilities: Avoid test on Watcom dashboards (#12034) 41f962a Revert "BundleUtilities: Run test on Windows if either MSVC or dumpbin was found." e17135e BundleUtilities: Add rpath to loadable modules in test. 8064044 BundleUtilities: Print reason for not loading module.so f3de459 BundleUtilities: Run test on Windows if either MSVC or dumpbin was found. 900bf98 BundleUtilities: Disable running test on Windows unless using MSVC. fa4dc08 BundleUtilities: Fix issues with custom target DEPENDS in test (#12034) e40b79e BundleUtilities: Fix test when using xcode (#12034) b68d3dc BundleUtilities: Fix regex to extract dependents from ldd (#12034) 7ac7b43 BundleUtilities: Work w/ non .app exes on Mac (#12034)
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index bf08b52..1be2a24 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -193,6 +193,24 @@ IF(BUILD_TESTING)
LIST(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
+
+ # run test for BundleUtilities on supported platforms/compilers
+ if(MSVC OR
+ CMAKE_SYSTEM_NAME MATCHES "Linux" OR
+ CMAKE_SYSTEM_NAME MATCHES "Darwin")
+ if(NOT "${CMAKE_TEST_GENERATOR}" STREQUAL "Watcom WMake")
+ ADD_TEST(BundleUtilities ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/BundleUtilities"
+ "${CMake_BINARY_DIR}/Tests/BundleUtilities"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-project BundleUtilities
+ )
+ LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleUtilities")
+ endif()
+ endif()
+
SET(CMAKE_BUILD_TEST_SOURCE_DIR "${CMake_SOURCE_DIR}/Tests/COnly")
SET(CMAKE_BUILD_TEST_BINARY_DIR "${CMake_BINARY_DIR}/Tests/CMakeBuildCOnly")
CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CMakeBuildTest.cmake.in"