summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-02-28 16:34:10 (GMT)
committerBrad King <brad.king@kitware.com>2012-02-28 16:34:10 (GMT)
commit5e1a5c44da395f8b2c121789e81f4a360a4088bc (patch)
tree795f42c91214bb545bfa7ab76fdf70789dc31a73 /Tests/CMakeLists.txt
parentd03606a19cc05872baf23269ae8ec61d2e0719e8 (diff)
downloadCMake-5e1a5c44da395f8b2c121789e81f4a360a4088bc.zip
CMake-5e1a5c44da395f8b2c121789e81f4a360a4088bc.tar.gz
CMake-5e1a5c44da395f8b2c121789e81f4a360a4088bc.tar.bz2
Add infrastructure for CMakeCommands tests
Generalize the build_command test framework as a macro to add the test. Process the CMakeCommands subdirectory explicitly.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9c97828..3a1453b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -48,6 +48,7 @@ IF(BUILD_TESTING)
ADD_SUBDIRECTORY(CMakeLib)
ADD_SUBDIRECTORY(CMakeOnly)
+ ADD_SUBDIRECTORY(CMakeCommands)
ADD_SUBDIRECTORY(FindPackageModeMakefileTest)
@@ -1695,13 +1696,6 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
add_config_tests(Release)
add_config_tests(RelWithDebInfo)
- add_test(CMakeCommands.build_command ${CMAKE_CMAKE_COMMAND}
- -DCMake_SOURCE_DIR=${CMake_SOURCE_DIR}
- -Ddir=${CMake_BINARY_DIR}/Tests/CMakeCommands/build_command
- -Dgen=${CMAKE_TEST_GENERATOR}
- -P "${CMake_SOURCE_DIR}/Tests/CMakeCommands/build_command/RunCMake.cmake"
- )
-
ADD_TEST_MACRO(CMakeCommands.target_link_libraries target_link_libraries)
CONFIGURE_FILE(